No reaction on Random Quote Generator

Why it’s not generating any quotes? Heres API which i use: Quotesondesign

And here link to my codepen project:

I’ve strongly “based” (for better understaing on simpler examples etc.) on this code: https :// (sorry i can’t add more links :confused: )

HTML has double closing tags for your button.
AJAX call URL is erroneous. (works fine with their most basic example URL)
MIME type check is erroneous.

1 Like

@jezzaho Try putting your Into the Codepen Settings under the HTML meta view settings.

The Chrome Inspector also said: /jezzaho/fullpage/js/main.js Failed to load resource: the server responded with a status of 404 (). This tells me that you are trying to connect to your JavaScript file which is not correct.
I see that you do have JavaScript code in your pen. If it is the same file then you do not need to call it again. If it is not then you need either combine it with your CodePen JS or load it onto a secure server and download from there.

The same is true for these two:

You can call the jQuery at the JavaScript settings by clicking on the dropdown menu and choosing jQuery. It will be added automatically.

CodePen does not recognize anything that is stored on your computer.

From there you should be able to fix the rest of it.

I hope this helps.

1 Like

@Puukallistaja @KoniKodes thank you for your time :slight_smile: Works fine now <3

So happy to hear that. I’ll love to see the final product.

1 Like

Here! Here I just kept that as simple as i can. I wanted to focus on script mostly for better understandment of code. That’s why CSS/HTML is " so pretty " designed but it does what it should do and I’m happy with the result :slight_smile:

This is awesome and beautiful!
I love the background image. Your quotes are great! I’ve shared one by tweet.
Good job.

1 Like

Very glad to hear it :slight_smile: Best motivation. Now wish me a good luck with Local Weather Website :smiley:

You’ll do great on the weather. Just remember that CodePen is a secure network and so your api should also be secure (https)