Not able to find the folder to run npm start

I have been trying to run a react.js web app together with a backend that is using VS code IDE. And no matter how I tried, I am not able get it run npm start.

I tried cd verious folders, all cannot work.

It’s been a few days and I really don’t know what to do with it. And I was reprimanded and threatened by unreasonable bosses to master react.js by 1 week. I have yet know how to do react with redux. …

Hope someone will help me on the above. Many thanks.

Are you sure the path to your code, and/or paths within the code are actually correct? Because the errors are Powershell telling you that the path you’re putting into the console doesn’t exist at all, you’re trying to run things that aren’t at the location you’ve specified

Hi @DanuCoupter,

the paths of the code should be correct. I don’t quite get you why it is not correct. I posted the structure at so that you can see for yourself. There is the 2nd half, but the first half you can tell what is the folder.

Please let me know if you see any problem.

I’ve got no idea what bb . co is because my browser just screams at me that it’s an unsafe site with a broken certificate, whatever it is can you post it somewhere else?

The pastebin you posted definitely seems to show you repeatedly trying to cd into directories that don’t exist

hi, are you able to view this one ?



Imgur: The magic of the Internet

](Imgur: The magic of the Internet)

Right, but in the pastebin, which I assume is just a copy of what you’ve been typing into the console, you seem to be trying to cd into non-existent directory paths. Like it should be cd path/to/my/client/directory then npm start: if you’re not in that directory it won’t work

From that image, it looks like you’re skipping the begin directory.

dear @jsdisco,

You saved my life !!! If not for you, till now I still can’t see what is in the browser. It’s been many days. Thank you so much.

Now, I hope to post another question because really I need a life line now for my task.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.