Not able to set Path environment variable to run nodejs from command line

Hi guys may be someone can help me out with this issue. This is the link to question i raised on Stackoverflow, you can find all the details regarding the issue there – Thanks in advance!!

Why don’t edit the Path without using the command line?
In Search, search for and then select: System (Control Panel)
Click the Advanced system settings link.
Click Environment Variables. In the section user variables, find the PATH environment variable and select it. Click Edit. Click OK. Close all remaining windows by clicking OK.

I did that too,numerous times,but when i am running the command npm bin -g, it still shows path not set in the env variable.I can’t seem to find any way around it even though i am following all the necessary steps.:slight_frown:

Sorry for my haste in answering redundantly.

I can’t seem to find any system variable with the name of NODE_PATH.Do i need to create one? I set the path in the PATH variable which was already there.

No problem at this point of time i appreciate any kind of help i can get.Thanks

I am using Windows 7 I am running the v 4.5.0 of node.My path is odd that’s what i think as well.Is there a way i can change this path, also what’s up with the folder name with a semicolon in it (npm;npm),I don’t know where did that come from, may be i was messing around too much with my system’s environment variables,who knows?!.
I am starting to get annoyed by Windows and its installation issues as well.

So you solved at least one of my problem.I added a NODE_PATH variable in the environment editor as for some reason it wasn’t there. I set its path which you gave me then i tried getting the version of npm via command line,and ran into some another kind of error not long after i realized i got rid of my Appdata variable( :smiley: ) I added the appdata variable setting it to its correct path and ran the command npm bin -g once again hoping everything was resolved, and yeah i am not getting that “path not set in env variable error anymore” but when i ran the command browser-sync --version it said command not found.

Now i am off to figuring out this issue maybe i need to install it again so that it can get installed at the correct path.At least i got one of the issue resolved.Thank you so much i can’t thank you enough for this, you are some kind of a coding ninja aren’t you? I thought that was a myth.!!

1 Like

Yeah that’s what the problem was. I uninstalled everything, and installed it again, now everything works fine. Even the browser-sync command not found issue is resolved.I can rest in peace now. Thank you so much!