Please help to transfer my pen from a local environment to Codepen

Please help! My pen works well on my local environment with no problem at all but it does not render when I tried to transfer my code to codepen. Here is the link "https://codepen.io/Alimama/pen/qJvQBm. There was a pop up window : ‘The URL “r” is invalid. Use the format https://domain/path.js’.
And there is the package.json if it helps:{
“name”: “random-quote-app
“version”: “0.1.0”,”,
“private”: true,
“dependencies”: {
“axios”: “^0.18.0”,
“jquery”: “^3.3.1”,
“react”: “^16.6.0”,
“react-dom”: “^16.6.0”,
“react-scripts”: “2.0.5”
},
“scripts”: {
“start”: “react-scripts start”,
“build”: “react-scripts build”,
“test”: “react-scripts test”,
“eject”: “react-scripts eject”
},
“eslintConfig”: {
“extends”: “react-app”
},
“browserslist”: [
“>0.2%”,
“not dead”,
“not ie <= 11”,
“not op_mini all”
]
}

Many thanks!

I remember having a similar problem when I tried to do this :slight_smile:

Replace:

class App extends Component {

with:

class App extends React.Component {
1 Like

You also can do that:

const { Component } = React;
1 Like

Thank you very much! :grinning: