PostgreSQL pgAdmin not working

I’m using a 64-bit Windows 10 computer and when I installed PostgreSQL and tried to open pgAdmin this is the error I get. I’ve tried solutions mentioned in the stackoverflow, but it’s not working. What could be the issue? Let me know. :pray:


Have you tried this one: link


This happens when a PGAdmin instance is already running but cannot be reached. To resolve this issue, delete all the files in the following directory:

To verify user:

  • open command prompt
  • type whoami
  • hit return
  • username in path above should match what is returned in command prompt

Then run PGAdmin4 again.

Also… A suggested solution on StackExchange for the NW.js has crashed error was to downgrade to pgAdmin III (link) - so if nothing else works…

Disclaimer: Amateur/Beginner here… Do wait for the experts before you decide to try downgrading…

Good luck troubleshooting :slight_smile:

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.