Problem with Bcrypt lesson

Tell us what’s happening:
The lesson gave me a new repl it link, but it doesn’t appear to be working. I’m getting an error that it cannot find the module express, which appears to already be configured from the base project.
(also apologies if I’m in the wrong forum subsection, javascript seemed closest)

Your code so far

Your browser information:

User Agent is: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/86.0.4240.198 Safari/537.36.

Challenge: Understand BCrypt Hashes

Link to the challenge:

Hi @sbrevolution5. Try installing the packages using npm install in the console as suggested in this topic. Hopefully it will fix your problem.

1 Like

Not sure what is going on, it really should install the packages when running the repl.

What’s odd is I just tested it and first it failed, then I opened the starter project again from the link on the challenge page and it worked. Can’t say I know what happened, might just have been a glitch.

once i typed in npm i (not the full install command) it gave me a much more detailed installation log, but it worked, Now I’m having issues on the next problem, as detailed here: Help with bcrypt hash compare

Sure if you npm install (npm i is just a shorthand for npm install) it will install the packages.

I was just commenting on the fact that for some unknown reason it failed to install the packages as it should when running the repl.

So theres no difference between npm i and npm install? it always shows a sort of loading bar? I’d never seen that happen before, which is why I’m confused.

Yes, they are the same, i is just an alias for install.

1 Like