Problem with taking Glitch url and using it as a solution for question


Any of the above solutions worked for me. Instead of using the “Share” button which provides you with an URL of this kind: (solid-stop is the name of my project) I’d rather suggest to use the following.

Here is the fix : (replace “solid-state” with the name of your project)


Thanks @NOLT, this worked for me

In my case the problem was more complicated.

Somehow Glitch was deleting files imported from Github.

So server.js was just empty.

I had to manually copy the content from server.js file on Github and paste it on Glitch.
The veiws/index.html was also needed.

The URL worked as described above.


I ended up using instead of Glitch.

  1. Import files from Github to Repl:
  2. Copy server.js content to index.js

This issue is still ongoing. I tried everything above and nothing worked. The issue is Glitch is not importing the files from Git, whether you use the link or if you go to git and copy the .git link.

The only thing that worked for me was to manually copy and paste all the files over from git to glitch.


I had the same problem. First I was getting the “JSON” error cause I was copying the wrong URL. Then I started getting the “Timeout” error. As @dkimble said above, the only thing that worked was manually copy and paste everything from git to the glitch project.

thanx, solved my query too.

thanks you, it work well, but, for someone that want to learn mircroservices it can be embarrassing.

same. i am so irritated right now. all of my enthusiastic optimism has instantly turned to mistrust on lesson one WHY FREECODECAMP WHY