Problems with creating react server


#1

When I try to create server, the console gets me this errors. Instead of save files into my folder, they were saved into appData folder.


#2

You tried installing it globally, so the files are not stored in your folder but in the storage location of npm (appData).

I suppose it works if you use the “open as administrator” option when opening the command prompt.


#3

I use open as administrator. Same thing


#4

I was typing without -g. It dose not work


#5

And if you use: sudo npm install -g react-create-app?


#6

I use Windows, so I can’t type sudo


#7

I just tried running npm install -g react-create-app with the Node.js command prompt and it worked fine, so I can’t really help.


#8

:disappointed_relieved:


#9

As far as I know it’s create-react-app; also according to the documentation:

npm install -g create-react-app

Sure you didn’t meant this?


#10

Can you be more specific?


#11

You did:
npm install -g react-create-app

while on the docs (assuming we are talking about Facebook’s initial bootstrapping and not another boilerplate) is:

npm install -g create-react-app

watch the name: create-react-app Vs react-create-app


#12

It’s still create errors. But when I later type create-react-app “some name” it works.


#13

So thank you for help