Python in Replit - No module named pytest

I am trying to start coding the first Python project, but Replit is against me. I tried several times to import freeCodeCamp starter template, but all the times, when I press Run or run “python” it says “No module named ‘pytest’”.

The replit.nix file is correct, as follows:
deps = [

So… what’s the problem?

Thanks in advance.

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36

Challenge: Scientific Computing with Python Projects - Arithmetic Formatter

Link to the challenge:

Hey, try approach that is in the following post - Loading nix environment doesn't stop - #4 by sanity

I’ve done the three steps and now I’m at this point:

./bolilerplate is empty, replit.nix is correct (?), still gives no module “pytest”

I’ve tried repeating your steps. The Run button at the top, or run python, but in the Console should work.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.