Quality Assurance and Testing with Chai - 1st challenge doesn't work

Tell us what’s happening:

The 1st test does not pass. I submitted the solution link from Gitpod boilerplate and I tried also to submit the link from Simple Browser and still doesn’t work. The solution is ok, because I checked the correct answer given by the Hint section.
I also tried solutions from other posts including commenting /* */ the tests that weren’t of interest in this challenge.

Thank you,

###Your project link(s)

solution: https://freecodecam-boilerplate-istkkt9tvnc.ws-eu115.gitpod.io

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36

Challenge Information:

Quality Assurance and Testing with Chai - Learn How JavaScript Assertions Work

I assume this is a link or a local host issue.

More information: How to Use Gitpod in the Curriculum

Did you remember to restart the server?

I just tested it using Gitpod and had no issue passing the test.

We can’t see your code. Follow the instruction on how to share your workspace.


This is not correct.

    test('#isNull, #isNotNull', function () {
      assert.isNumber(null, 'This is an optional error description - e.g. null is null');
      assert.isNotNull(1, '1 is not null');

null is null, not a number. So it is isNull

Sry, i tried it so many times that the snapshot i took was wrong :)))
Here it is again

Your code is passing for me.

Make sure you use the correct URL. Click the PORTS tab in the bottom panel and use the URL that starts with 3000-



// running tests
All tests should pass.
You should choose the correct method for the first assertion -




. You should choose the correct method for the second assertion -




. // tests completed

Doesn’t pass…

Post the URL you used.

Make sure your Gitpod is running (keep it running for now).


thx, i kept it running in the bg and after it refreshed it was ok.