RDB Curriculum - Docker - Starting New Tutorial On Windws

I’m attempting to go through the “Relational Database” Course which uses Docker and Visual Studio on Windows.

After finishing the first tutorial ( “Learn Bash by Building a Boilerplate”) I attempted to start the next tutorial (by running CodeRoad: Start) but was presented with the following image.

So far, the only way I found to start a new tutorial is to clone the GIT repo in a new folder and go through the “How to Run a Project in Docker” steps listed on the course description.

Anyone have any tips, hints and/or suggestions? Thank you very much!

Course Link

1 Like

I am not sure of how to fix it. I am running into some problems myself and its taking me a while to figure things out. If you do figure out maybe post how you fixed it? May help others like use who are doing this. Good luck with your course and hopefully it goes smoothly.

1 Like

Hi @kaijuking28 !

Welcome to the forum!

I haven’t had to reclone the repo each time.
So, I am not sure why yours isn’t launching the new tutorial.

Maybe you can try exiting the terminal and closing coderoad.
Then you can use Ctrl / Cmd + Shift + P and choose the Remote-Containers: Reopen Locally
Then you can use Ctrl / Cmd + Shift + P and choose the Remote-Containers: Rebuild & Reopen in Container
Then try CodeRoad:Start

Hopefully those steps work for you so you can use the same rdb-alpha folder for all of the projects.

Good luck!

1 Like

Hello! Thank you for the reply!

What would be the best coarse of action once I complete a tutorial? It is at this point where all the trouble with trying to start another one occurs.

If I click on “Open New Workspace” the “Open Folder” drop down at the top of VS opens.

Thank you for your help. Much appreciated. :grinning:

I have never done two courses in one session so I haven’t experienced this issue of trying to open a new workspace after finishing a course.

What has worked for me was to just exit out of everything.
And then when I am ready to start a new tutorial I just go through the start commands and it has worked for me.

1 Like

Also, Tom has a section about switching to new projects in his article.
So you can run those commands to see if that works

It took multiple attempts but (following your suggestion) I closed out VS and then relaunched it using the cmd line (code .).

After waiting for a few minutes the option to “CodeRoad: Start” finally appeared and I was able to start a new tutorial.

I did try Tom’s notes about switching projects but when I first attempted to do so it did not work for me at the time. Not sure what happened but for now seems like things are working.

Thank you so much for the help and suggestions! :grinning:

Note
When I was encountering the initial issue (where CodeRoad displayed the “Oops! Select an empty workspace” message), closing and relaunching VS from the cmd line did not help resolve the issue for me (at the time).

What seems to have helped this time around was, after completing a tutorial, closing out VS and relaunching it again. :crossed_fingers:

1 Like