React Native build error

today i started learning react native and beginning with a todo app by creating project using react-native init Todo after installation of all modules when i run react-native run-android. it throws error

but my env variables are all set good

whats wrong ?

UPDATE - tried configuring variables more than ten times . can someone help ?:disappointed_relieved:

Yeah, for me, the hardest part about React Native was getting the environment set up. It took me at least a week.

To me it sounds like the JAVA_HOME is not properly set. Iā€™m suspicious of that semicolon at the end. What do you get if you type:

$ echo $JAVA_HOME

in the terminal?

thanks for helping me out , i figured it on my own yesterday .The problem is with environmental variable ( yeah the semicolon ) placed in USER VARIABLES section the semicolon appears even i saved without placing it i dont know why its still placing semicolon on its own,i think its a bug in windows 10 so i deleted JAVA_HOME variable and placed in system variables :smile: . It worked.