Hey Contributor Team,
We are going to rename references to the old Master-Slave terminology throughout freeCodeCamp and its documentation to the less charged Primary-Replica terminology. This is already used by documentation of IBM, Microsoft, AWS, Python, and the ACM.
I went through freeCodeCamp’s publication and updated references to “slave” and “master” with more contemporary Primary-Replica terms.
But we need to do this with GitHub, too. For each of our repos, we need to change our default branch from “master” to “upstream” or something similar. I think GitHub is going to start doing this by default for new repositories, but we will need to do it ourselves and migrate it over.
Would any of you be interested in helping take charge with renaming these GitHub branches and updating our Readme.md, Contributing.md, and other GitHub documentation?
Here is the GitHub issue: