Replit keeps timing out after Chai tests

I’m doing the 2nd and 3rd projects for the Quality Assurance certification, and for both of them, when I don’t have the NODE_ENV set to “test,” all of the requirements pass for FCC except the last one: “All functional tests required are complete and passing.”

Then, when I do have the NODE_ENV set to “test,” all of the tests are complete and passing in the console, but the Replit times out after the tests are over and can no longer connect to FCC.

I’ve looked around the forums and seen others with this issue, and I’ve tried the few fixes that they’ve suggested, but nothing has worked. I’ve tried changing the port, commenting out the “dotenv” requirement, using a VPN, commenting out the example test, etc. but nothing so far.

Here are the links to the Replits:

https://replit.com/@sssmsm/boilerplate-project-issuetracker
https://replit.com/@sssmsm/boilerplate-project-library

Please let me know if I’m missing anything, and any help is greatly appreciated!

Well I brute force solved this, if anyone else is having the same problem.

For both of the projects, I eventually got them to pass by setting the timeout from 3500ms to 9500ms in the server.js files, and then quickly clicking “I’ve Completed This Challenge” after making the Replit go live. If failures started to show up on the FCC page, I clicked again.

After about 10 tries each, they passed.