Quality Assurance and Testing with Chai - Learn How JavaScript Assertions Work

Hey guys,

I am not able to go forward with this project because of “Timed out” session.

I completed the first and second step as described but still no luck. It says Timed out (on the: All tests should pass) while the remaining two pass.

I tried stopping the test while it was loading during Replit Wake up, still can’t continue even with stopped test.

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36

Challenge: Quality Assurance and Testing with Chai - Learn How JavaScript Assertions Work

Link to the challenge:

This is a common problem with repls when trying to run QA tests from FCC, as they crash your repl. However, it should work if you do the following:

  1. Complete required code for challenge
  2. STOP your repl
  3. Submit your repl live link to FCC website

When you click to submit the challenge, FCC will wake your repl and the tests should pass before the repl has a chance to crash again.
In later challenges (such as the certification projects for this course), you will have the option to run the QA tests only when you need to, so you can work on other parts of your code with it constantly crashing.


I did that, I still get the erorr message for "All tests should pass. (Test timed out).

Is there any fix for this?

Can you share a link to your repl please?

Yeah, sure!

This is the repo:
boilerplate-mochachai - Replit

Hmm, I passed these tests ages ago but now I can’t get my repl to work either. Perhaps someone else might have a better idea!

Ok, I had another go and clearly you’ve made no errors in your code, so the issue lies elsewhere. I managed to get my repl to pass the tests eventually (having come up against exactly the same issue as you). To do this, I had to start the repl and wait until the ‘tests running…’ message appeared in the console (but before the repl had a chance to crash again). I quickly submitted the challenge to FCC and (after several attempts) I timed it sufficiently well that the challenge passed successfully.

This issue has come up time and time again but no-one seems to be able to offer an explanation or fix for it.

Unfortunately still the same error. Tried with Running tests and then clicking on I’ve completed this challenge but still nothing.

I got a solution for this problem. What I did is basically, stop the replit. After that, I copy the link of my webview then paste it in the solution link. Then here’s the important part. Start the replit and wait for html output which you will see " Automated Testing
Functional Tests Example" in the webview. If you see this output in the webview, immediately go to the freecodecamp then click submit “I’ve completed this challange”.

This how I pass the challenge. I hope this works for you too.

It seems that this fixed the problem. It needs to show the “Automated Testing Functional Tests” example and then be fast enough to click on “I’ve completed this challenge”. Thanks Gabriel and Igor for providing with solutions.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.