Resposive Web Design - Technical Documentation Page

Hello everyone, I am a bit confused while testing my “Technical Documentation Page” . I cannot pass this line error.

Screenshot_2020-03-13 Fork Me FCC Test Suite Template(1)

4. Each element with the class of “main-section” should also have an id comprised of the innerText contained within it, with underscores in place of spaces. The id may include special characters if there are special characters in the respective innerText. (e.g. The that contains the header, “JavaScript & Java”, should have a corresponding id=“JavaScript_&_Java”).

We need to see the full code. Post a Codepen link with your code and the test script added.

It may be that the capitalization is mismatched

Also, look at the first line below the failing test. That often gives useful info on how to correct.

Thank you lasjorg , here is the link to my codepen project.
https://codepen.io/Aly_Kane/pen/BaNrYKe?editors=1010

this is the failing test:

  1. Each element with the class of “main-section” should also have an id comprised of the innerText contained within it, with underscores in place of spaces. The id may include special characters if there are special characters in the respective innerText. (e.g. The that contains the header, “JavaScript & Java”, should have a corresponding id=“JavaScript_&_Java”).

And right below it there is written this:

Some "main-section" elements are missing the following ids (don't forget to replace spaces with underscores!) : WEB_DEVELOPEMENT

let’s see your code:

ah, spelling…
there is a character of difference

ah ah ah!!! spelling… you’re right. Thank you once again ieahleen!
It’s OK, the button is green right now. And I am singing, dancing, and prying for you.
Now it’s time to focus on the content.