Results ain't working

Tell us what’s happening:
I’ve solved the problem successfully. But nothing approves when I run the tests on the website.

Describe your issue in detail here:
My results are okay if I do them manually. I doubled checked it many ways for many times but nothing happened.

  1. I compared the test results to provided demo as well. (they match)
  2. I’ve checked my server logs. we good!
  3. I went through other solutions. (same)

I don’t understand what’s up. I think I am just an amateur. Help please!

Your project link(s)

solution: https://hasnat-timestamp.herokuapp.com
githubLink: GitHub - hasnat-hybrid/timestamp-microservice: This is the solution to freecodecamp.org certification challenge.

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:100.0) Gecko/20100101 Firefox/100.0

Challenge: Timestamp Microservice

hello and welcome to fcc forum :slight_smile:

is it some backend related project?

also it will be better if you share that project link here as well for more clarity,

thanks :slight_smile:

Yes! it is the first project from the backend certification.

then add "backend " to your topic tags and provide that project link for convenience :slight_smile:

I’ve added the link to the challenge but not sure how to add multiple tags for to the post.

I’m seeing a CORS block in the browser. Try moving your cors code in index.js up to before your app.use with your routes (or move the routes down after it).

Jeez, man! that worked…
getting different results now. Thank you so much. Can you explain a little bit what was happening?

The cors package is middleware and has to be used before the routes (like the middleware logger you create in the basic Express challenges).

1 Like