Running Django on a Replit?

I recently finished a Django project (CS50’s Commerce project) and uploaded it to a Replit to try and run it there.

It worked perfectly the first few times I ran it. I had to copy/paste the URL into a new window, but I could access everything just as if I was running the project on my own machine.

But now, whenever I run the project, I just get this Fluxbox thing instead of the website I made.

I’m not sure what changed, or what Fluxbox even is, but any help would be greatly appreciated!

Replit link:

Could be some kind of resource limitation; I tried to run the site and it wouldn’t load. When I forked it, I found the problem: matplotlib. It opens the GUI for some reason when loaded or called to produce plots. I’m not sure if it always does this so maybe the behavior can be avoided if you don’t use plot() or other functions that try to display graphics.

Fluxbox is a window manager for unix systems (the GUI display); uses it for the window manager in repls. You click on that screen and exit fluxbox if you like.

1 Like

Hey thanks! I forgot about the matplotlib libraries that I didn’t end up using, so I went ahead and deleted them.

I tried running it a couple of times after that, and it still didn’t work, but then an hour later when I tried again it did work so I don’t know what to make of it, haha. Replit can be a bit finnicky…

Anyway, thank you again and much appreciated!

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.