Time Series Visualizer - Repl.it won't run


I am working on the time series visualizer - I have built everything originally in Jupyter Notebook (and it worked fine) and then transferred it to the repl.it to see if it passes the tests, but the code will never fully finish running.

When I run the code the first time, it will compile all of the packages and then say:

Starting X
. . . . .
but it never gets further than 5 dots, even if I let it run for 15+ minutes.

If I stop it and try to run again, a lot of time it won’t even say “Starting X . . . . .”, it will just sit there.

I have re-forked the original repl.it, tried using a different browser (edge, normally chrome), and even tried pasting in someone else’s code that was posted in one of the forms (in case I had some kind of infinate loop in mine that I wasn’t aware of). In all cases the same thing has happened.

I have been stuck on this all day.

Does anyone know what might be going on?

My code is here:


This is because of plt.show() line in drawing functions. It makes repl.it stuck here when plot is displayed. It’s not needed for function to save plot to file and pass required information to tests, so you can safely remove it.

Thanks sanity,

I took that out and it worked as expected.