Scientific Computing with Python Projects - Arithmetic Formatter

Hello i’m having problems with the import main module, it says module is not callable

Your code so far

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/120.0.0.0 Safari/537.36

Challenge Information:

Scientific Computing with Python Projects - Arithmetic Formatter

It looks like you have two ‘main.py’ files? There should already be one there in the boilerplate for this project. You shouldn’t create a second.

I’m pretty sure you have to import main from py.test, not from main.py.
Try changing the import to from pytest import main

Nvm I didnt notice you had the main.py twice like Jeremy said.

i didn’t create another one, it was in the hidden files

There should only be one main file. It sounds like the repo cloned incorrectly

wait lemme redo it , also how do i select the use run command? i also get error like sh:1 use: run command


what should i do here? i always ended up configuring the .replit file afterwards

I ran into that same issue, someone else mentioned writing python3 main.py which worked. :blush:

wait what? what did you type in the configure?

Just literally: python3 main.py

In case you are past this step, you can configure it in your .replit file

or type python3 main.py where it says “Enter a command to run” in your screenshot.


Screenshot 2023-10-02 073220