Step 15 - New Responsive Web Design : BUG?

Hi there !

I’m stuck at Step 15 of the new responsive web design course. I have to create 4 inputs after my 4 label texts. I’ve done exactly the same for the 1st label as for the 3 others. But it keeps telling me i have done something wrong for the 3rd input (but not for the 2 first inputs?).

Can someone explain to me why i have an error on the 3rd input but not on the other 3 inputs? And what do i do wrong? I suspect it might be a bug otherwise

 <fieldset>
        <label>Enter Your First Name: <input></label>
        <label>Enter Your Last Name: <input></label>
        <label>Enter Your Email: <input></label>
        <label>Create a New Password: <input></label>
 </fieldset>

Thanks in advance for your help !

(PS : i’ve read the other topic about that exact step. But the other guy was doing something that was not working from the 1st input so it seems to be not the same issue here)

Do you mind adding the name of the section you’re on as there are many “step 15” in the curriculum. (or you can link to the question which is even better)

Also include the course name as well as the step. There are a lot of courses here and it is not always obvious which one you are working on.

But, the snippet of HTML you pasted here works for me. Please paste in your entire HTML. There may be something else you accidentally changed.

Yep sorry ! The section is “Learn HTML Forms by Building a registration form” : it’s the last section before the certification project “survey form” of the (New) Responsive Web Design course.

So to sum up :

  • Step : 15
  • Section : Learn HTML Forms by Building a registration form
  • Course : (New) Responsive Web Design

Direct link to the page : https://www.freecodecamp.org/learn/2022/responsive-web-design/learn-html-forms-by-building-a-registration-form/step-15

Entire Code (in case I changed something else accidentally like bbsmooth suggested) :

<!DOCTYPE html>
<html>
  <head>
    <title>Registration Form</title>
	  <link rel="stylesheet" href="styles.css" />
  </head>
  <body>
    <h1>Registration Form</h1>
    <p>Please fill out this form with the required information</p>
    <form action='https://register-demo.freecodecamp.org'>
      <fieldset>
        <label>Enter Your First Name: <input></label>
        <label>Enter Your Last Name: <input></label>
        <label>Enter Your Email: <input /></label>
        <label>Create a New Password: <input></label>
      </fieldset>
      <fieldset></fieldset>
      <fieldset></fieldset>
    </form>
  </body>
</html>

Can you show us the css code? (This step is about css so without seeing it we don’t know what you have done)

(At least the link you gave is about css, maybe that link is wrong)

Yep, that’s weird… The link I had was the one i wrote, but now when clicking on it, it’s the previous step (Step 14), now labelled as Step 15… Very weird… We can see on the image in my first message that Step 15 is the one talking about “inputs”.

And now, it seems that it is Step 16 which does that :
image

Very weird… Maybbe the freecodecamp dev are currently working on that course and making changes?

Now the updated link seems to be : https://www.freecodecamp.org/learn/2022/responsive-web-design/learn-html-forms-by-building-a-registration-form/step-16

1 Like

Your code passed for me when I cut and pasted it into the answer box.
Maybe you should try:

  • click “Restart Step” and acknowledge
  • refresh the page (reload the page)
    then paste your answer and check again
1 Like

I already tried “restart step” and refreshing the page and it didnt work :frowning:

But thanks to your reply where you aknowledge that my code should work, i tried something else : changing my web browser !

Until now, i was working on the course on Firefox. I then tried with Chrome and surprise, it worked !

I don’t know why, there should be no reason why it doesnt work on Firefox (and especially when only the 3rd input seems to be a problem) but at least now i know that what i wrote was fine, just a bug with mozilla or something !

Thanks for your help ! My problem is now solved, using Chrome as Web browser.

I can tell you that I use FF for everything with FCC and didn’t have a problem passing this step. Maybe you have an extension installed that is causing the test to fail? But ya, if switching to Chrome works, then I’d just stick with Chrome.

1 Like

Yep, totally possible : I have some extensions installed on Firefox, which i havent on Chrome. So you might be on to something !