Step 60: Make first radio button checked by default

The task is to add the checked attribute to the input element so the first radiobox is checked by default. I have the “checked” attribute already in my code. But the editor will not let me pass. The problem instruction is as followed: " In order to make a checkbox checked or radio button selected by default, you need to add the checked attribute to it. There’s no need to set a value to the checked attribute. Instead, just add the word checked to the input element, making sure there is space between it and other attributes.

Make the first radio button and the first checkbox selected by default."

i can see, ‘first radio’ button is selected already!! but you’re still getting this error?!

yes. i think the editor has a problem. it won’t let me proceed

did you try ‘hard refreshing’ your browser or try changing browser ,see if that changes anything

btw, welcome to fcc forum :grinning:

I’ve tried deleting all the history(including cache). Using a different device and submit the code there. restarting my pc and still nothing worked.

could you please share that ‘task link’?


it passed!!

but i had to tinker it a little, i first put ‘cheked’ into somewhere wrong (in checkbox), got error message saying ‘radio button’ needs it, then 'put it there , baaam ‘passed’!!

it did not work for me. i’ll try my workplace’s wifi tomorrow

I added another checked to line 44 after for=‘loving’ and it worked after that!


You need to set the first radio button to default by using ----checked

we have 2 (columns), so you need to use ----checked the first button from each (columns)

1 Like

HI,
I had the same issue. we need to add the checked on both radio button indoor and loving.

you guys can link your code so you dont have to take a screenshot by following this gif

Thanks alot , This had me sweating for minutes
:saluting_face: