Submitting code for certification

Hi, I’ve completed two tasks from the relational database series, but I cannot submit them for the certificates. Every time I try I get attacked by the pink banner that admonishes me saying I “need to complete the task first.”

My understanding was that I need only store the files on a public repository somewhere and provide the link. I currently have them stored on a public repo on github. Is this wrong? Is there another repo I should use?

How can I claim the certificates?


please provide links to the fcc project page that you are working on to get specific suggestions and/or help.

In most cases the links discussed by the projects is requested to be a live URL (such as on replit or anywhere such that your website is live).

Here is a link to the project page:

Thanks for your suggestion hbar1st, I tried replit just then but still could not submit.

what was the url you used?
I just read the link you provided.
They want the github repo link

I was trying this link: GitHub - user101a/FCC: Freecodecamp repo

Is that the wrong link?

the link is not working as you said. How did you confirm that you completed the project?

Well all the tasks were completed with green ticks, and a blue banner popped up saying I was finished.

It was the exact same with the number guessing game task too (


The message you “need to complete the task first” means that when you completed the project, it didn’t get saved to your freeCodeCamp account (“Step 1” on the project page). Something maybe just went wrong with the request. You should be able to complete that by following the steps here. I think they’ve worked for pretty much everyone with a similar issue.

After you get the checkmark by that “Step 1”, you should be able to submit your URL.

Hi moT01, thanks for your help. I’m not sure I quite fully understood what I should do. I tried reloading the VM by opening up another course, and then opening the course I wanted to submit again. No progress was saved in the course, so presumably it expected me to do it again. And yeah, I wasn’t able to submit the completed files.

Was this the correct course of action to try, or did I misundstand?

There’s three things to try in that link I shared. The main one is clicking that continue button in the screen shot. It sounds like you did the third thing listed - after you did that, you should have clicked that continue button. I would try those few things again, I don’t recall an instance where those steps haven’t worked for anyone - sometimes it takes people a few tries cause maybe they missed something or it just didn’t work quite right.

As a last resort, you could save your files somewhere locally, delete the container, start the project again (new container), load your files in there, and submit. You shouldn’t have to do this though. I’m pretty confident those other things should work. Let us know if anything works :+1:

Hi moT01. Thanks for your help again. In the end I had to take the last resort and re-do the project (with the completed files) in a new container, but it worked.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.