Relational Databases Cert - Finished Projects in Codeally Account

Hello FCC,

I am currently moving through the Relational Databases Certification. The lessons that I completed within CodeAlly aren’t showing up as completed in my FreeCodeCamp profile, which seemed like it wasn’t a big deal because they were in my CodeAlly account and I clicked on the “finished” button after I completed them. However, when I try to access them in CodeAlly, I can’t, though they still appear in the Playground page.

I guess the only one that really matters at this point is the Celestial Bodies project because that is required for the certification, but I was trying to go back and refer to one of the old projects for my current project, the World Cup database. Is there any way to access any of those to either submit them to FreeCodeCamp as completed projects or refer to them for my current projects within the certification course?

Thanks again for providing these certifications, they’re great.


have you tried to launch any of the projects from the fcc site?
This may trigger the site to get the updates from codeally.

1 Like

Hey, yeah I have tried that and it doesn’t work. I get the screen that shows “Loading environments” and so on, but it doesn’t go anywhere, it stops at the “Starting virtual server” point. I discarded the virtual environment that contained the code from the Learn Bash Scripting by Building Five Programs because I couldn’t access it and I couldn’t remember some of what I needed to know for the World Cup Database project, now I’m just going back through that, which I obviously needed to do, lol. It’s all good, though it would be nice to not have to go through and build the Celestial Bodies database again, if I can get access to that somehow. It looks like in the future I should just make sure to copy and paste the code onto my github page so I don’t lose anything. Luckily I haven’t made it too far yet. Do you think I can get access to the Celestial Bodies project to then submit it?

Have you tried this troubleshooting step from the pinned post?

  • start the project in one tab and let it try to load for a minute. Then, open another tab (don’t close first one) and start that same project in the new tab.

I have tried that, it was actually the only way I was able to open the code editor in CodeAlly. Each time I log in, I have to click on the project in the Playground page, then when the “loading environments”, etc is running through its steps, I wait until it reaches the “starting Virtual server” point, and then I right click and duplicate the tab, then it would launch the editor.

Now when I go the Playground page in CodeAlly, if I click on a FINISHED project, it flashes to the screen that says “loading environments” and then jumps back to the Playground page without loading the environments at all.

Is there any way to access the sql file that would rebuild the database from the project that CodeAlly has under my account, or should I realisitically just go back and rebuild that Celestial Bodies project? Just trying to get a sense of if it’s possible or not, I read on the forum that it’s not super easy to get in touch with CodeAlly and get support. Those files from my completed projects should be living out there somewhere, right?


just wanted to clarify something.
Have you tried the troubleshooting step -from fCC’s website- (not CodeAlly).

I believe so, I’ve tried lots of different combinations of what is described in the general post that outlines troubleshooting options, in both CodeAlly and fCC.

One thing I haven’t done is sign out of fCC yet because it says that my progress won’t be saved, I’m going working my way through another certification and I’m worried that I’ll lose that progress too.

Anyway, as usual it’s pretty hard to describe, but I can try to do a better job if that would be helpful.

To recap:

  • you are unable to ever sign into the relational db courses through the fcc website, even with any of the tips given in the troubleshooting doc (like reloading, or opening one tab and letting it load then opening another from fCC)

  • you’ve been doing the courses by logging in from CodeAlly (hopefully using the same email account that you use for fCC sign-in)

  • some (but not all) lessons are showing up in fCC as incomplete. Specifically the ones you completed via the CodeAlly site.

  • you are unable to return to the finished courses (either through fcc or through codeally and you’ve tried both ways)

  • The Celestial Bodies project was completed but again the same issues mentioned above apply. There is no acknowledgement you can see in the fCC site that this project was submitted/completed.

  • You essentially really would like to somehow get access to the SQL file saved to the virtual environment to recreate your Celestial Bodies project (and ideally to successfully submit to fcc)

Okay, so given all this, I do hope that the course developer is able to help you with some suggestions. I think one final thought I have (other than to urge you to confirm the above and to re-confirm that you really have tried all the troubleshooting steps via the fcc site), is to try to email the codeally support person to ask if he can help you access the celestial bodies VM. I believe the email is

That’s correct, thanks again for going through it all with me, I appreciate it.

I’ll reach out to them and see what they say, all the best.

  • Eusebius
1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.