[COLLATION]: CodeAlly - Relational Database

05/09/2023: CodeAlly does not start properly. Or, if it does start, the editor is unusable.

We are aware of the issue, and are looking to resolve it. For now, it is recommended to follow the instructions to run the course locally.

This topic will be updated as information changes.

12/09/2023: The issue has been resolved and the projects should start normally again.

15/09/2023: Unable to log in. bad-verification

Issue: unable to log in: bad verification code · Issue #62 · freeCodeCamp/CodeAlly-CodeRoad-freeCodeCamp · GitHub

25/09/2023: Deployment has been disabled. 402 Resolved

17/09/2023: Login loop


build-a-mario-database and other projects have the same problem. Please help me
I press green button “Run with CodeAlly” and nothing happens


    "operationName": "AddProject",
    "variables": {...},
    "query": "mutation AddProject($name: String, $description: String, $isPrivate: Boolean, $repoLink: String, $teamId: ID, $organizationId: ID!, $forkedFromId: ID, $hiringType: HiringType, $timeLimit: String, $tags: [String], $difficulty: String, $envsFromParams: [[String]], $isEmbed: Boolean) {\n  addProject(name: $name, description: $description, isPrivate: $isPrivate, repoLink: $repoLink, teamId: $teamId, organizationId: $organizationId, forkedFromId: $forkedFromId, hiringType: $hiringType, tags: $tags, difficulty: $difficulty, timeLimit: $timeLimit, envsFromParams: $envsFromParams, isEmbed: $isEmbed)\n}\n"


    "errors": [
            "message": "Cannot read properties of undefined (reading 'find')",
            "locations": [
                    "line": 2,
                    "column": 3
            "path": [
            "extensions": {
                "code": "INTERNAL_SERVER_ERROR"
    "data": null

I have the same problem for the past few days


I was eager to start the Certificate course on Relational Databases and I saw the notice by FCC on it being under maintenance. That maintenance message could use some updating such as what is under maintenance and how long it is has been such… and if there is any expected completion date. Anyways, different from what others I’ve seen are experiencing, after I have connected Github with Codeally and come back to the Run with CodeAlly button… when I click on that button, it quickly flashes a list of steps it is trying to take to set up the environment but then just returns to the Run with Codeally page. I’m not sure if this is related to the “maintenance” or something with my set up. I am on Ubuntu 20.04, running chrome, 3rd party cookies are enabled and I have no VPN running. I have followed the steps in the referenced forum page at the top of the Database Course page. Nothing has worked. This seems like it has been a huge frustration for more than a year now. What is the latest on this whole situation?

I cannot run CodeAlly or it gives me a bank space. It was working fine unit yeterday.

Please help,

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36

Challenge: Learn SQL by Building a Student Database: Part 1 - Build a Student Database: Part 1

Link to the challenge:

1 Like

Same problem here Freecodecamp bug

Hopefully someone who can help comments soon, but indirectly bumping your post by commenting in a bunch of other threads won’t help us fix this faster, unfortunately. It’d sure be convenient if code worked like that though.

Does this forum exist to ignore questions? I ansered them because I found the reason. Also the description of the cause of the error will help to fix the bug faster.

Please do not spam multiple topics with a link to your question. Your question doesn’t provide these users with a way to help fix their issue. Also, spamming doesn’t help the maintainers fix the issue faster.

Hey there, in these last few days I started backend development but neither codeally and replit are working

1 Like

I hope developers will notice this bug Freecodecamp bug and fix it :pray:

I am trying to run the relational database course and says that codeally.io certificate is expired or something like that, the thing is I cant get access to the course, someone else has the same problem?

What can I do? Its gone be fixed?

1 Like

Same here. Have anyone reached out yet?

1 Like

I’m just wondering if any of the relational database courses work properly for anyone? Perhaps the worst part is that there’s no warning indicating that something is wrong with the server, so you can’t be sure where the error originates.

1 Like

Its not working on any browser, there no more warnings apparently but is not running at all


It doesn’t working because of internal server error Freecodecamp bug

CodeAlly is failing to load any of the Relational Database courses. Checked the console and I see the following two errors:
(12 instances of:“The resource was preloaded using link preload but not used within a few seconds from the window’s load event. Please make sure it has an appropriate as value and it is preloaded intentionally.”
(3 instances of: “Node cannot be found in the current page.”
Thanks for any help!

Hello and welcome to the community :smiley:!
I’m sorry that I can’t help with that, but I did notice that two others had posted having the same issue a little while ago. Hope this helps.

1 Like

Thanks! I noticed that too, and it seems like FCC staff have started maintenance on the course again. Hope they figure out what’s up. Next time I’ll wait a bit before starting another thread on what could be a common problem.

1 Like

Unable to start any course in Relational database section. Getting below message when clicked on Start project.

1 Like