[COLLATION]: CodeAlly Status


CodeAlly does not load at all, or it does not load with the correct configuration (the file system is not set up).


See suggestions


Until this problem is resolved, we suggest running the courses on your local machine. Here are the instructions to do so:

Thank you for your patience during this outage :slightly_smiling_face:


CodeAlly not running in Learn Relational Databases
I click the run codeAlly button but it stops loading. Also throws error in inspect.


Yes, this has been raised in another thread. I’ve hopefully alerted the powers-that-be to it!

I having same problem also

Same problem with different error code:
Request Error Performance 862 addProject

Maybe it’s because it’s the weekend but so far we’ve had complete radio silence from FCC staff on this issue I think.
@Cryptic_X can you help please?

You are not alone. Same problem here

It’s working for me, now. Whoever put in hours on a Saturday to get this fixed, thank you. It means a lot to be able to keep up the momentum on a specific course, and your efforts are very appreciated.


Hello. I am also having problems with codeally not loading. And when it does load, a completely blank terminal comes up with only the chance to make a soft reset that leads back to de start course page. I’ve tried several times and always ended up in the same situation

I shut down the session for a while and when I returned and tried to run commands, it says “bash: /home/codeally/project/.freeCodeCamp/test/.next_command: Read-only file system”. I’m not even able to open nano interactive env in the terminal, can anyone please help with this, are there any concrete solutions to this problem, i even tried giving permissions to the json file in the repository but it doesn’t seem to work.

Same is happening to me LOLz :smiling_face_with_tear:.

beta versions sigma problems :))

I think the team is making a revised version of the environment or like so, so many issues i have been facing from past 1 week in this course.

ikr same and the course is freaking loong, its good but very long

Same here. I am in the Relational Database Course. (Using Chrome)

Same issue student database section

yeah experiencing same thing as well. Been trying everyday for past 3-4 days, no luck

I cannot connect to the codeally vm. I have been trying for the past few days.

Hello. Upon following all the steps and loading virtual server, I am getting this. Is there a way to fix it?