CodeAlly having an outage?

I can’t seem to access any of the Relational Database courses right now.

Does anyone know what the problem might be please?

EDIT: Actually I can access any courses which I haven’t started yet. All other courses, complete or incomplete are unavailable now.

Thanks for the report. I am having the same issue. Hopefully we can sit tight and the codeally support will respond in a reasonable amount of time.

Hi, I’m nearly finished the “Learn Bash and SQL by Building a Bike Rental Shop” project in the Relational Databases course. I tried logging on today and I’m getting this error, screenshot below.

I just tried opening the other assignments and only the ones that aren’t completed are running fine. The ones that I have started already or are complete are showing the same error.

Your browser information:

User Agent is: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36

Challenge: Learn Bash and SQL by Building a Bike Rental Shop - Build a Bike Rental Shop

Link to the challenge:

Thank you for reporting! We’re investigating the issue!

Thanks a ton for reporting quickly!
It’s hard to reproduce on our end, but we found a potential cause.
We made a temporary fix that should do it.
If it works for you, we will be able to make a permanent fix.

Please let me know if it works for you @igorgetmeabrain @hbar1st @naf !

1 Like

it is not working unfortunately

Edit: no, just tried celestial bodies project and it came up. I will try a few more.
2nd edit: world cup db project is working too.

looks like that fix is working @AdamZaczek

1 Like

I’m glad to hear that!

@AdamZaczek thanks for the quick response - everything appears to be working again now!

Hi Adam,

I’m still having issues getting into the database course on CodeAlly. When i click “Run With CodeAlly” the “Checking Permissions” spinner spins for a second and stops, and the screen reverts to “Run With CodeAlly”

I’ve tagged @AdamZaczek already in another post. Many people are reporting this. Hopefully it will be addressed soon.

Can you share a link to that post so I can follow for updates

Hey it seems it has happened again :frowning:

I am facing this same issue while trying to access the Mario Database course…

1 Like

It is not working for me too.

1 Like

It is not working for me too.

1 Like

I’m experiencing a similar issue - I have tried on both Brave and Firefox.

Getting that same error as well xO

CodeAlly if having a outage. Is it just my machine?
Good opportunity to start working on the back-end courses.

1 Like

Sometimes life can be as simple as RTFM. CodeAlly is back up. Must be my tendency to ignore adverts on other sites but I just noticed the red writing that’s on more than one page! ( see screen shot below ).

It’s best and recommended by freeCodeCamp to work the courses in order. But if a section is down you can either work on it locally or skip to the next section. If you’re saying to yourself “well duh I knew that already” then good for you, you’re ahead of the game.

Did your problem get resolved?