Website is not working

Hello, I tried using FreeCodeCamp on my iPad and it doesn’t seem to work. When I open up the page, it is just a blue background. I tried downloading the chrome app on my iPad to see if that would work and still nothing. It lets me use FreeCodeCamp on my iPhone but not iPad I’m not sure what to do in this situation. I really want to use it on my iPad.

5 posts were merged into an existing topic: [COALLATION]: CodeAlly Status

After a month of trying it works now? Not sure why it wasn’t before, I hope I don’t run into this issue again.
Edit: same problem is happening again, not sure what to do. I finally had it but once I cleared my history and tried getting back on the website I had the same issue.

Well, on my iPad it automatically sets to Safari and that does not work. I tried using the Chrome app and had the same issue. I had it working for a second and unfortunately when I cleared my history the same issue occurred. I’m just not sure what is going on it works perfectly fine on my iPhone. My iPad is not broken or anything any other website works just not FFC, it is just a blue background.

Umm, what does CodeAlly have to do with this? I’m really confused about why you moved my post. I’m not trying to use VS code or anything I’m just trying to load up the FreeCodeCamp on my browser which does not seem to work. It allows me to post here because I’m using my Chromebook. I just get a blue background screen when I go to the FCC website on my ipad browser, I can show you a picture if you want.

Apologies about that. I was moving a bunch of posts, and yours got caught in the cross-fire.

I have moved it back to the original topic.

Thank you, but do you have any solution to this problem? I’ve been trying to use FCC on my iPad for a month now and no luck. I had it working for a bit yesterday but cleared my history for some reason and the same issue occurred when I tried to load it up again. Do you want to see a picture of how it looks? It is just a blue background.

Sure, a picture might help.

Would you also share your browser user agent?

I’m not sure how to get the browser agent user on an iPad but this is what comes up when I try and load up the FCC website.
Edit: it’s not blue my bad but yeah same issue

Thank you for the image.

Would you mind going here and sharing the user agent in the blue box:

What does that information help you do? Will that help me find a solution? Not sure what a user agent is and if my information can be stolen, not saying you will I’m just a bit skeptical. Do I just click the link and copy and paste what it says?

It helps us test the platform on a specific version/kind of device.

I am unsure. It is the logical next step I often go to.

The User Agent is explained on the above mentioned site. In short, it details the versions of software on your device. JUST operating system type + version, and browser type + version - no other software.

Every help post automatically generated from the curriculum on the forum includes this information (if available). If that helps ease you

Yes. On the device you are experiencing the problem with.

In short, it will help cross off common device issues:

  • Outdated browser
  • Outdated OS (operating system)

Also, we can then use tools such as BrowserStack and/or LambdaTest to mimic your device, and see for ourselves what the problem might be.

Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_6) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/15.0 Safari/605.1.15

I cannot reproduce an error on either of the following devices:

  • iPad Pro 12.9
  • iPad Air 2
  • iPad 6

The tooling I used does not have the same OS version, but does have the same Safari version.

Is there a reason you use Catalina on your iPad? This seems odd, because most recent iPads would be on iPadOS 13 through 16.

Pretty sure I got an iPad 6. Just a bit weird since I had it working 2 days ago but when I cleared my history and tried getting back on the website the same problem occurred. So there is still hope it could work I believe.