Freecodecamp not working

What’s going on with freecodecamp guys? It’s behaving very strangely last couple of days including today that don’t get anywhere when I click get started. Also tested at too lessons were taking forever to load crashing often and also even if it loads it would load as if I had not signed in and after a while only show that I signed in. I tried in Opera Browser Windows 7 and in Google Chrome through my android phone had problems in both. Time to time it did say that we are updating.

I was wondering what was going on? Are you guys rolling out new curriculum? Or what’s causing the problem.

Also freecodecamp forum also had one problem since forever like it was same one year ago and it’s same still now. I have to try refreshing multiple times then only the site loads.

Hello there,

We are not aware of any issues on the platform other than the one outlined here for Safari users: [SAFARI] Curriculum Pages Stuck Loading

As Windows 7 is no longer supported by Microsoft, as of January, we cannot guarantee any reliable experience on such software.

No. Nothing new has been rolled out, in the last few months - other than typical bug fixes, and updates.

As I said, on unsupported software, we cannot guarantee a stable experience - this goes for both OS and browser versions.

As we are unaware of any issues on the server/codebase’s side, it is likely on your end. We do continue to work on the platform and infrastructure, but suggest you do some debugging such as investigating your internet source to ensure nothing is being blocked by either your router settings or ISP.

I hope you are able to resolve any issues experienced, and that this has clarified some questions you had.

Well it did work after clearing history and all but still not as well as it used to. Every single website works perfectly fine/smoothly except freecodecamp which works as if something is wrong with the server like loading after multiple tries even if it loads then does not load logged in view etc

Well, it isn’t an issue on our end.

2 posts were split to a new topic: Problem Setting Birthday

Maybe. I read that you were having problems in Safari, Firefox(yes I did experience it too in Firefox) and now my current browser too(Opera).

It’s not that it’s not working completely, just not working normally.

We have no guarantee anything will work on Windows 7. We are aware of a problem with Safari on macOS and iOS, but that sounds like a different operating system and browser than what you have.

The above link mentions problems in Firefox too. And like I said it’s definitely not the issue with Windows 7 as every single website is working normally/without any problems/smoothly.

Today it’s working. Last 2-3 days it was having problems like even if I click get started and all still at the same page or pages taking a lot of time to load or even if it loads then the sign in information was missing.

The Safari issue is ongoing, so what you’re experiencing is different if you are not seeing it now.

Actually I take back my words. It’s working but still not working normally like when I click the Get Started button it refresh and brings me to the same page. And after I click it 2-3 times it takes me to the curriculum.

Also website loading is going on, on and off like one moment it takes forever to load and another moment loads instantly. Doesn’t happen with any other websites like Youtube or Reddit.

Here you go. I have seen this multiple times in the last few days!

Not sure why you’re getting that message. We are not doing some large scale maintenance right now.

It was working fine but since the last 2-3 or so days or so it had been like this:

  1. When I click the get started, it doesn’t take me anywhere but the same page. Only when I clicked it multiple times then it took me to the next page.

  2. Lessons/challenges were taking forever to load too from time to time.

  3. Even if it did load it loaded a page which would load as if I had not signed it. Only after a while or after refreshing, it showed that I had signed in that is it marked the lesson as being completed.

  4. When it comes to freecodecamp forum, I was having this issue since forever like even one year ago: the page fails to load until I refresh it several times. It was the same case when I used MX Linux and Firefox, it’s the same case now too every now and then.

  5. I also experienced the same problem with Freecodecamp website, when I tried checking it on Google Chrome in my Android phone.

Now too at this very moment, as I type this, the website is not loading. Every single other website is loading fine and without any issues like Reddit, Youtube etc

The website loaded after like say 1-2 minute or so and even when it loaded the images of people in the front page did not load, it’s blank there. I see something new too: a sort of loading bar like a white thing going from left to right next to the freecodecamp logo.

After 1-2 minutes more the images now loaded and the loading thing stopped too.

But again when I clicked on get started it got stuck in the loading animation like white all around the the couple of black bars in the center. It was stuck here for 1-2 minutes then finally loaded. (During this time that is from the time I clicked get started to the time it loaded the content, I open Youtube in another tab and started playing a video and it worked normally there)

Right now once I enter the Javascipt curriculum page, I clicked here and there, eveything seems to work fine. But again in another tab when I opened the website it again is taking a lot of time to load.

1 Like

The error where it says maintenance is going on says this when I click on the details.

Connection timed out

The initial connection between Cloudflare’s network and the origin web server timed out. As a result, the web page can not be displayed.

  • Ray ID: (Hiding this idk)
  • Your IP address: (Hiding This)
  • Error reference number: 522
  • Cloudflare Location: Kathmandu

By the way I’m not complaining just informing. I am grateful to have access to this platform and grateful to all of the people who have put their time and energy into making this website and the forum and keep it going. So thanks to all of you.

Edit: The challenges also stuck on loading for a while finally loaded after like a 1-2 minutes or so. So I can work on it so it’s good for me for now. But like I said I have been working in this certification for over a month and was not having any issues until the last 2-3 days. So hopefully we can resolve it somehow.

1 Like

Thank you, for the detailed responses.

Would you mind changing your DNS config? If you are unware how, please search in your favourite search engine.

Personally, I find the most success with Google Cloudflare :


Hope this helps

1 Like

I do have the IPv4 set to Cloudflare since the beginning. Might have to see the IPv6. Thank you.

This is terribly disappointing…Think I will close this account and go coursera. They have their act together.

If you have a technical problem, please describe what is happening in a new post and we’ll help you sort it out.