[SAFARI] Curriculum Pages Stuck Loading

Issue
Some or all pages do not finish loading on freecodecamp.org for Safari browsers.

Recommendation
Use another browser

More Info

Since the last two days or so, I noticed that I cannot access API Microservices and Quality Assurances courses. There’s no problem accessing other courses. Clearing caches and history didn’t have any effect.

I tried Chrome, and it worked, so it seems to be a Safari problem. Do you have any suggestions to regain access from Safari?

User Agent:
Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/14.1.1 Safari/605.1.15

Thanks for your help.

Hello there,

This is likely the same as Project Description/submission pages do not load on iOS devices · Issue #42431 · freeCodeCamp/freeCodeCamp · GitHub

Sounds like downgrading your OS version might work, but I do not recommend this.

I am going to combine this for a mega thread, until the issue is resolved.

I completed all html & css courses & now I’m trying to move onto the “build a tribute page” but the screen is stuck in a loading screen. I don’t know what to do.

Hi @Jcorales !

Welcome to the forum!

Are you using safari?

Yes I’m using safari. That image is exactly what I’m getting lol

I have moved your post with the others.

An issue has already been opened.

You can follow along with the progress by clicking on the link.

For now, I would try and use another browser.
I am on google chrome and can access the tribute page.

Hi everyone, it seems to me that the FreeCodeCamp website has broke on Safari web browsers across Macs, iPhones, and iPads.

Attempting to open the responsive web design challenges on all platforms result in nothing. Attempting to open the links in a new tab results in the endless loop of loading. I have a screen recording of the issue here as well for a visual:

This issue was demonstrated on a MacBook Air (M1, 2020), But the issue persists on my iPhone 12 mini running iOS 14.6, and my iPad (6th Gen) running iPadOS 14.6 as well. I don’t know if this has to do with Apple’s end or FreeCodeCamp’s but I thought I would report it to let it be known.

This may be related to:

Please, can someone suggest why i cannot open the ‘Responsive Web design Projects’ . I have been trying from yesterday but it just keeps thinking!
Thanks

Try on a different device . Does it works there?

Welcome there,

Are you using Safari?

1 Like

Yes , do it matter if i am using my ipad

I have moved your post to this mega-thread, where we are tracking an issue with Safari.

Thank you! Should i be using google in the meantime . Also i have gone into my iMac and it has not saved all my previous work . Will i have to go through them again?

Google Chrome has proven to be the most reliable browser, in terms of the curriculum, but there are others which should work - up to you.

You do not have to do anything. If you want to claim a section’s certificate, then you do need to complete the 5 associated projects.

However, provided you are logged in to an account, and connected to the internet, as you complete the curriculum, your progress (not code) will be saved. Also, provided you have no browser extensions blocking the website’s requests.

Hope this clarifies

1 Like

Hello,

The projects section of the Python certification aren’t working. I click on them and there isn’t any sort of redirection.
Also, when completing the last lesson, it stays stuck in loading and won’t go to the first project!!!
Please help!! I want to finish this course and the projects are the best part of the certifications

Welcome there,

Would you mind providing more information?

  • Which browser are you using?
  • What device are you using?
  • Which challenge are you trying to access?

The more information you provide us, the more likely we will be able to help.

Hi, I’ve been using Safari, and now switching to Chrome has solved the issue! Thanks a bunch for getting back to me.