Sudoku Solver Tests break server hosted online

Tell us what’s happening:
Hey guys,

I have managed to complete the technical challenges of the project am looking at clearing it hosting it on REPL without luck.

It seems like, only when hosted on REPL (as opposed to locally using vscode), after running the tests the application seems to crash for some reason?

If I disable the tests everything works fine but when I enable them they run and pass before the application goes offline. I have tried looking for this online or enabling some sort of logging to understand what happens.

Everything works fine when it is hosted locally using vscode.

In order to replicate, you can fork my project, create a .env file and copy the following content

PORT=3000
NODE_ENV=test

And then run it. The tests should run with the UI loaded and after a few seconds it seems to crash.

Has anybody seen something similar before?

Thanks

Your code so far

https://repl.it/@LaurentLabine/boilerplate-project-sudoku-solver

Your browser information:

Tried both chrome and firefox just to make sure and I don’t believe it’s browser related.

Challenge: Sudoku Solver

Link to the challenge: