Test in codepen has a bug

Hi! I’m here to report a problem I found in the 25 + 5 Clock test and would like to know if there is a solution.

After repeated attempts, I managed to successfully complete this test. But I was stuck for a long time at 24/29 tests passed. Seeing that one of the tests that failed was the 19 (9. If the timer is running, the element with the id of “time-left” should display the remaining time in mm:ss format (decrementing by a value of 1 and updating the display every 1000ms)) and seeing that it actually worked correctly, I tried modifying the setInterval() time. I changed the value from 1000 to 50 and ended up getting a 29/29.

image

It’s clear that this shouldn’t work like this, but it’s also clear that my code was working correctly. I imagine the test execution time is the problem, but I’m not sure. If it is not, what should I change about my code?

I’ve done it twice, once with React only and the other with JavaScript only and both times the same problem appears.
REACT | JAVASCRIPT

Thanks!

@JeremyLT Could you help me?