Test not running after updating

Tell us what’s happening:

this is the code to the button that wont respond to run test

Your code so far

Run the Tests

var myStr; // Change this line

**Your browser information:**

User Agent is: <code>Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/71.0.3578.98 Safari/537.36</code>.

**Link to the challenge:**

The above is not a valid Javascript syntax
You have to assign values to the myStr variable like so:

var myStr = "FirstLine\n"; 

But this is still an incomplete answer, you need some addtional escape strings along with SecondLine and ThirdLine text. (Read the challenge requirements)

I am mainly talking about the fact that when I hit “Run the Test” it will not process, or it will only process every so offten/randomly. it started after i updated my hp, i have reset my laptop and still wont work, it works on other computers such as my phone and i have tried diffrent browsers. i dont know what happen in the 12-24 hour period that i stopped the program

FirstLine\n <--------------------------- This is not valid Javascript. So your code will not even run.

You likely accidentally deleted some code. My suggestion is to simply click the “Reset All Code” button.

ok so i reset all code and i press “run the test” ( without even touching the bored because normally it will it will just say everything is wrong or w.e because it hasnt been touched) but nothing happens so the icon with the test tubes stays the same, sometimes it runs other times it doesnt. it doesnt have to do with the code

Try reloading the page, try an other browser - sometimes the tests are not compatible with the browser you are using

i tried, i tried donating to see if it would change something but still nothing i am so disappointed.

What browser have you tried? Try with Firefox or chrome

I am sure that FreeCodeCamp is grateful for the donation, but that wouldn’t magically fix things

i have chrome im downloading FireFox right now i hope it works on there…

still not able to run code on firefox

What happens when you press “Run the tests”?

nothing the button clicks(turns a slightly different shade of green and goes back) then nothing. it just started mid way through my first java set.

Can you try to use FreeCodeCamp in privacy mode? Can you try with an other computer?

Just a note, this is not java, this is JavaScript, they are as similar as ham and hammer

See the other posts for other things to try

If you can’t find a way to run FreeCodeCamp you will need to open an issue in githup because it will need technical support from someone that knows a bit more

I have tried several other devices and it gives me the same bug. I just tried privacy mode on both firefox and chrom i think its the website, its just weird that it just popped up so randomly. one day it was working fine the next… cant get through one item… other people have been having this problem since 2015 thats what i saw online…