Test Runner Failed (Learn Bash by Building a Boilerplate - Build a Boilerplate)

Tell us what’s happening:

Hello! I recently started this course. In first step, as you know, I have to enter “echo hello terminal” in terminal for next step. So, I entered this sentence and pressed enter. But I couldn’t go to the next step. I checked a lot of times and executed. However, there is an message “Test Runner Failed” for each execute.

I’ve search how can I fix it. I’ve tried all kind of reset such as …

  • Soft reset in the green hamburger menu at the left top
  • Pressing reset button next to the run button
  • Reset tutorial in the code road setting
  • Deleting user token in my free code camp setting
  • Deleting cash in chrome setting
  • Rebooting computer
  • Restarting web browser

After doing some of things, suddenly, I was gone to the next level without passing “echo hello terminal”. And I can’t go back to the first level with above ways. Moreover, even though I entered “pwd” correctly in this level, I couldn’t pass with “Test Runner Failed” too.

I really want to learn this course. Please help me to fix my problem.

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36

Challenge: Learn Bash by Building a Boilerplate - Build a Boilerplate

Link to the challenge:

1 Like

I’ve finally solved!! I could fix this through delete code ally cash. Thought I didn’t get any answer, I think I don’t need help for this problem.


same problem facing please help me
what is delete code ally cash how to do it please help

That problem was due to missing files. So, you may fix this problem via initializing code ally data. I don’t remember how I did well, I think I probably deleted code ally page cash through browser setting. I hope you solve your problem. If you have more question, ask me anytime. :smile:

I can’t continue from this part. It shows the runner is not working. Can you tell me what to do please? I am stuck.

You could try deleting your container and restarting the whole process. Your progress will be lost if you have any but try to make sure coderoad properly installs when you are setting it up again.

1 Like