Trouble Signing In


I have tried signing in to the curriculum portion of FCC, and keep getting the error message “Oops! Something went wrong. Please try again later”. I enter the correct email and password and this still happens. I have even tried going through Github, but the same problem occurs. Has anyone else had this problem?

Sounds like maybe you were trying to log in while the servers were not responding. Has the problem resolved itself?

It has not. I also tried creating a new account, but that did not work either. I will also try again later.

You may be having problems with your ISP, a VPN or a proxy blocking access to FCC’s hosting service.

Thanks! Do you know some steps I could take to pinpoint the problem?

If you’re using a VPN, try connecting without the VPN. Try accessing FCC from a network that uses a different ISP. Try using a proxy to change your region. Look at any settings that you might have enabled that would impact network traffic.

1 Like

I haven’t been able to pinpoint it yet. I don’t use a VPN, and I can log in with my phone whether I’m connected to my wifi or not, so it shouldn’t be impacted by ISP or proxy either.

Try clearing the cookies and search history and then signin it might get resolved

I have also tried this, but it didn’t help either.