Trouble with Markdown Previewer

Hi. So let me get started. I… Hate… JAVASCRIPT!!! I’m looking so forward to being done with the trash front-end libraries. The only good thing I’ve learned from these projects is that I am a back-end developer. I can handle HTML and CSS, for the most part, but I absolutely hate front-end design and anything to do with Javascript.

Alright, now that I’ve got that off my chest, let’s get into my problem. So on my markdown previewer, I can’t figure out why the heck the example is working, but mine isn’t. I literally can copy the exact code from the example, and it still doesn’t work, even though I’m using the same preprocessors from the example. The only bug is in the Javascript, and it says “Uncaught ReferenceError: marked is not defined.” I think I saw some other people have this same issue, and they fixed it by a library import, but I don’t exactly know how to import libraries into a CodePen pen. Please help me out with this so I can finally be done with front-end garbage.

On the left of “JS” there is a gear icon. Click it. Search for marked.

1 Like