Unable to open/view projects in Codepen

I’m trying to use CodePen for the first time but I am unable to open or view projects. If I go to the example link from FCC, I get sent to a “Connection Reset” page, if I try to open something in CodePen it’ll open but the preview just shows “connection reset.” How do I fix this? I have tried with and without adblocker in multiple browsers, always with the same issue.

That sound like a CP issue.

Can you provide a link to the pen that is giving you an issue?

It’s anything I open on the whole website.

I don’t know. I can’t confirm that a link works for me until I know what the link is.

Look in the console and network tab for errors (F12 > console and network tab). You can post a screenshot.

Considering it is happening in multiple browsers it sounds more like something local to your network, like some type of blocking for example.

I would try a different DNS and test using a VPN as well. Search for Public DNS and free VPN. I don’t really want to promote VPN services here but if you search for it the service that starts with “Proton” is one you can give a go.

1 Like

Thank you! The VPN fixed it. Not sure why, maybe it has something to do with the country I’m in, but the simple VPN Chrome extension did the trick.


That’s good to hear.

But it’s a bit unfortunate that you have to use a VPN. There are other online editors like Codepen you can try as well.

Works very similar to Codepen

Editors that are more like a real local dev environment

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.