Use turtle in geany

How can i use the turtle mode in geany?

You go to the pet store and buy a turtle XD but jokes aside maybe it’s a good idea to tell us what version of geany you are using. and check if your file is recognized as python source file?

also i found the 2 next sollutions online from stackoverflow.com
2

I had the same problem and found the following solution:

in the ‘Build Options’ dialogue click on ‘_Execute’ at the bottom of the Dialogue and the _execute options become editable.

I put the full path name to my Python install in there (C:\Python27\python %F) or (C:\Python32\python %F) and it seems to work just fine.

Also Don’t forget to set the “KeyBinding” ie the keyboard Shortcut-key (single or combination) you press to activate “Run, Execute , Compile, Save, Find, Print etc…

To do so; Edit -> Preference ->Keyboard Shortcuts. Here you can Choose/Change any Key/s to map to any Action you want.

Why? Because some other Linux Program might have overridden, or might have taken the default Geany assigned map Key/s

My version is Geany 1.32.