Visual Studio Python setup

hi, i have watched different you tube videos to setup my visual studio code install with some extentions too and python 3.7.8 install but it does not look like visual studio is able to see the python.exe path though i could execute my one line hello world in the command line. could you please help me add a path so that i could continue learning python?

The installer should have added the path to the environment variables. Not sure what OS your are on?

How are you running the code, just from the command line or what?

VS Code has an extension AREPL for python you can check out as well.

i am on windows and am not running from terminal. i try running via run without debugging. i could not see a standalone ‘run’ button.

i will also explore AREPL after i get this intall working. i have googled what the path should be but the problem is am not even sure where to add the path on the

Did you save the file with the correct file extension before running it ( If you can run python code from the command line I don’t think the PATH is the issue.

What exactly happens when you run the file in VS Code?

BTW, it works just fine for me and I didn’t have to do anything special. Maybe try reinstalling Python and make sure the add to path option is checked.

so, i re-installed python in the morning and that did not fix the issue. am uninstalling vscode now to re-install after,

yes, my little hello world was saved with hello

in most cases when i go to view>run’ it does nothing. when i run with/without debugging, sometimes it would complain about path.

hi lasjorg, it loos like i just had a success with your help. it seems that the path was the problem. vscode was grabbing onto a deleted python interpreter. now corrected by forcing it to use the newly installed python interpreter. thanks a million for your help