Voting App Project - EASYPOLL

Voting App Project - EASYPOLL
0.0 0

#1

This is the live app https://votingfcc-computerluca.c9users.io/#/
This is the github source code https://github.com/computerluca/votingfcc
The app is not perfect, but works!
I’d like to hear your comments and suggestions!


#2

I found an error:

When I voted on an existing poll, it added my vote to the wrong bar on the chart.

Personally as a user I’d prefer some changes to the UI as well. When I created an account I would like to either be automatically logged in and redirected to the homepage, or redirected to the login page.

Also, when creating vote options for new polls, clicking on the option field should clear the existing text rather than having me manually delete it. You can use placeholder text to do that more easily.

Good work so far.

I just started coding mine last night, so I’ll look more closely at the code when I finished :slight_smile:


#3

Also your axis behave strangly. It might be better to have them fixed (and start at zero).


#4

I corrected the chart. Now it works better than before. Can you check?
When the user created the account, after a few seconds if the registration is successfull, my application redirect automatically to the login page.
I corrected also the creation of option in the poll. Now the option of the poll is cleared by the application automatically.


#5

Doesn’t seem to load for me on mobile. Using Android and Chrome if that helps.


#6

It’s not loading at all for me at the moment (Desktop Chrome).

Console says this, if it helps:

Refused to execute script from 'https://raw.githubusercontent.com/VictorBjelkholm/ngProgress/master/build/ngprogress.min.js' because its MIME type ('text/plain') is not executable, and strict MIME type checking is enabled.
angular.js:38Uncaught Error: [$injector:modulerr] http://errors.angularjs.org/1.5.8/$injector/modulerr?p0=votingfcc&p1=Error%…erluca.c9users.io%2Fbower_components%2Fangular%2Fangular.min.js%3A20%3A390)(anonymous function) @ angular.js:38(anonymous function) @ angular.js:4640q @ angular.js:321g @ angular.js:4601cb @ angular.js:4523c @ angular.js:1758Bc @ angular.js:1779fe @ angular.js:1664(anonymous function) @ angular.js:31763b @ angular.js:3207Sf @ angular.js:3497d @ angular.js:3485

#7

Can you retry?
Thanks


#8

Ok I’m in.

I registered a new account and it worked well, with a nice UI. Logged in easily.

I clicked on the old poll I’d made but it showed this:

In fact, all polls look like that.

I was able to add my own poll, but again, clicking through to vote on it didn’t work. Also, the options still require me to manually clear the input box before typing.


#9

Can you refresh the page?


#10

Looks good to me :slight_smile:


#11

This is the new URL of the app https://quick-dutchess.hyperdev.space/#/