What am I doing wrong ? please help

it keeps saying that I don’t have action set to abitrutes which I pretty sure I did

  **Your code so far**

<h2>CatPhotoApp</h2>
<main>
<p>Click here to view more <a href="#">cat photos</a>.</p>

<a href="#"><img src="https://cdn.freecodecamp.org/curriculum/cat-photo-app/relaxing-cat.jpg" alt="A cute orange cat lying on its back."></a>

<p>Things cats love:</p>
<ul>
  <li>cat nip</li>
  <li>laser pointers</li>
  <li>lasagna</li>
</ul>
<p>Top 3 things cats hate:</p>
<ol>
  <li>flea treatment</li>
  <li>thunder</li>
  <li>other cats</li>
</ol>
<form action="submit-cat-photo">
  <input type="text" placeholder="cat photo URL">
</form>
</main>
  **Your browser information:**

User Agent is: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/15.1 Safari/605.1.15

Challenge: Create a Form Element

Link to the challenge:

Your form should have an action attribute which is set to https://www.freecatphotoapp.com/submit-cat-photo .

What is your action attribute set to?

its supposed to be /submit-cat-photo

No it isn’t.

1 Like

ok ill try that but I’m pretty sure I did before and it didn’t work

still saying I did it wrong I’m unsure if its my browser

What is your current code?

<form action=/"https://www. freecatphotoapp.com/submit-cat-photo">
  <input type="text" placeholder="cat photo URL">
  </form>

I’ve edited your post for readability. When you enter a code block into a forum post, please precede it with a separate line of three backticks and follow it with a separate line of three backticks to make it easier to read.

You can also use the “preformatted text” tool in the editor (</>) to add backticks around text.

See this post to find the backtick on your keyboard.
Note: Backticks (`) are not single quotes (’).

Why do you have a / at the beginning? It also looks like you have extra spaces in the url.

2 Likes

I did it thank you so much I appreciate