When I click Curriculum it wants me to sign in

When I click Curriculum it wants me to sign in

1 Like

the curriculum and forum accounts are two different accounts, do you already have an account for the curriculum?

I am having this problem as well. FCC changed the signup page and it’s not working properly. Please advise as to when it’s going to be fixed. It’s not saving my progress on the challenges this morning. Problem is definitely on the FCC end.

1 Like

I’m having same issue as well. When I sign in, I’m signed in and directed to the home page. When I click on “Curriculum”, I see no progress and a big “Sign In” button in the upper right hand corner.

I’m having the same problem - have tried using a different Internet browser & have tried signing out and then signing back in. Still, when I click on curriculum is signs me out. :-/ I hope this is resolved soon.

if you are using github or google to login, change to using email

use your email to login

Same Issue with jlewis. It just started sometime ago

I use my email and I still have the same issue

1 Like

Doesn’t work unfortunately. My default is logging in with my email. I tried on Chrome and Firefox, with the same result.

i was facing the same issue but after i logedout and sign in with my email everthing was okay

sorry but it worked for me

Are you sure? How can it be working for you and not working for so many other people?

believe me i was facing the same issue earlier, all i had to do was logout and login via email and voila

I’ve logged off and on. Still hasn’t worked for me.

I’m unable to reproduce this problem. Is it still happening? I have a suspicion that the curriculum might be getting updates or moved around on servers and that caused (or is causing) intermittent issues.

I am logged in to my FCC, I click on curriculum it puts me where i was currently coding a challenge but i see the button to log in but how can this be if i am already logged in just a moment ago??? So i click login and login… I am put to the welcome page i can go to my profile and seems to be in order… but as soon as i go back to the curriculum i am back to square one. its a continuous loop. i cant continue my challenges … I can but i am not logged in. i have cleared my cookies i ate them all :slight_smile:


Same problem here, both in Chrome and Firefox

Same here. Looks like it was a problem for some people last year, but I can’t find any info on a fix.

Same here. I’m using GitHub to log in and thought that was the issue, but have no issue with other sites I log into with GitHub.