Can’t login to the curriculum


Each time I try to login using my email and the one time code it fails saying:

“Oops, something went wrong. Please try again in a moment”

I’ve left it a day and it’s still saying that - can anyone advise?



I’m having the same issue as well. Tried logging in with GitHub and email, clearing all site data before trying either one, and attempted in Chrome & Firefox - same issue except Chrome lets me login and then does not update any tests completed at all.

I also get the message “Oops, something went wrong. Please try again in a moment” when trying to login with GitHub. Have been trying periodically since Friday night with no luck. Can’t sign in from any browser or device. Tried chrome, ff, edge, and chrome on mobile. No luck. Please help!!

1 Like

@ArielLeslie - I appreciate you linking this, but considering it was last updated 17:00 California time on 10/18, I’d like to ask if there is any new information from the devs? When can those of us experiencing this sign in issue expect to access fCC again? Even though /learn is working, it’s not helpful to those us us who can’t login and have our progress and solutions recorded.

It was last updated on Friday because that’s the last time there was an update. If it’s important to you to get the little checkmarks, you can save your solutions until you are able to sign in.

@ArielLeslie - Hey, those little check marks are the drug you’re pedaling after all, so don’t hate me for wanting another hit :laughing:

In all seriousness, I’m sure you and all the other mods and devs are being bombarded, so thank you for your time and effort. I feel like maybe my comment came off as rude, so please forgive me if so. It wasn’t my intention. I’m merely anxious to continue progressing, earn certificates and be exposed to the opportunities that fCC enables through this platform.

Don’t worry. I’m sure you’ll be getting that sweet validation soon. Our #1 concern is making sure that everyone has access to the materials, but we do understand how hiccups in experience can throw people off.

Hi everyone,

We have fixed all the authentication issues with the learn platform at, if you are coming back to freeCodeCamp after a while, chances are you have had a duplicate account.

There is no outage issue on the main learning platform as of now. Although we are seeing some login issues on this forum itself, which is being investigated separately.

Please email us at

Thanks for your patience.

Happy coding.

@ArielLeslie @raisedadead - I actually may have discovered something else. I still couldn’t log in this morning, so I had a hunch and decided to go into GitHub and start messing with some things. I reset my password, changed my primary email address and disabled 2 factor authentication in GitHub. I did so in that order and tried logging into fCC after each change. It wasn’t until 2FA was disabled that I could successfully log in…so at least in my case, 2FA seems to be the culprit.

Thanks for letting us know.

To the best of what I understand 2FA will not be a factor. We use the OAuth 2.0 to connect GitHub via Auth0 (our identity provider). This means regardless of what you have as additional protection the authorization to prove your identity comes to Auth0 via OAuth 2.0.

In simple terms, our API only cares about the email that is received by us, nothing else. As for not being able to get into the curriculum is because of account duplications that happened way back last year.

Unfortunately, this means we need to fix these records by merging them manually. You can email us at to get this fixed.

Dang, I thought I was onto something. Regardless, I wish you luck in solving the lingering problems.

I have updated my comment on the issue thread here to give you all more insight into why this is happening:

Chances are you have a duplicate account.

How to fix?

Please email us at and we will get this resolved for you.

But why would I have duplicate accounts?

Back in June 2018, we had updated our platform. At that time, a bug had caused account duplications for some users.

With the recent Oct, 2019 update to the platform, we have identified that the bug was fixed but the account duplications remain in the database. These unfortunately have to fixed by our team manually. Users have progressed with the curriculum since last year and a programmatic fix may not be possible.

None of your progress is gone or lost. They are simply lying in a different account with the same email address or username attached to it.

Does this affect how I login? Can I use GitHub or other logins?

We simply rely on the email address that is received by us, as long as GitHub, Facebook, Google are returning the same email you have with us you will be signed into your correct account.

Thanks for your patience, and understanding with this. The newer platform is more resilient and we look forward to your feedback


I still can’t login and I’m one step away from getting my first certification plus I want to start on JavaScript - any updates?


Is it possible that a browser extension or network setting could be interfering with your connection to the freeCodeCamp servers?


I’ve tried accessing via my mobile (on the mobile network) and my laptop on my home wifi but nothing works - I keep getting that same message. I’ve tried signing up with a different email and that works so would that not mean it was something at FCC’s end?

Many thanks

Thanks for checking that. I think you’ve reached the “email” phase of troubleshooting. (See raisedadead’s post above for some context.)

Thanks yeah I sent an email a couple of days back but nothing back so far

Check your spam filters. freeCodeCamp emails seem to get aggressively auto-filtered. Also, please try to be patient. I understand how frustrating this is, but there is a very small team of dedicated people doing their best to serve the needs of thousands of people.

1 Like

I suspect there is a backlog.