When I click the #submit element, the email is submitted to a static page (use this mock URL: https://www.freecodecamp.com/email-submit)

Hi guys!

I have a question regarding the Product Landing Page Project. I have almost completed this project except for one of the tests that is incomplete:

When I click the #submit element, the email is submitted to a static page (use this mock URL: https://www.freecodecamp.com/email-submit).

This is what I added:

 <form id="form" action="https://www.freecodecamp.com/email-submit" method="post">

 <input type="email" placeholder="Your Email" id="email" name="email" required>
          <input type="submit" id="submit" value="Subscribe">


However, when I run the test, it still does not work.

If anyone has any suggestions for me, please feel free to let me know! I have been staring at this for a really long time.

Thank you so much!

Maybe try removing the method = “post”? It looks fine to me.

Thank you for the fast reply! But it didn’t work :frowning: I’m still not sure what to do now.


When you run the tests, what does the error say? When you click on the button tests, you should see something like this:


Thank you for the reply. I have screenshot the test here:

Weird… There’s no problem with your form (I copy/pasted it into a project that was passing, and it still passes), so could you share your entire project?

In the meantime, some things you can try:

  • Make sure that every tag is correctly closed. For instance, that every <p> has a corresponding </p>, every <a> has a corresponding </a>, etc.
  • Also, check that every attribute value is enclosed in quotes. A missing quote may be a problem.

Both this problems could be fixed by using the Analyze HTML button:

1 Like

Wow thank you @skaparate I didn’t know there was a HTML analyze button! I will definitely try that out!

Thank you again @GhostRoboXt and @skaparate for the help!

Did the analyze HTML button help you out? I cleared my HTML and any small issues it had with this feature but the form action issue still persists.

if you read the error below the failed user story there is usually written what the error is

Yes, did that and solved it, thanks :slight_smile: