World Cup Database - Build a World Cup Database

  • Your two script (.sh) files should have executable permissions. Other tests involving these two files will fail until permissions are correct. When these permissions are enabled, the tests will take significantly longer to run

I don’t know what i need to to atm and how can i run this script? L

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/105.0.0.0 Safari/537.36

Challenge: World Cup Database - Build a World Cup Database

Link to the challenge:

What are the permissions set to on your script files?

(You can use ls -la *.sh to see if they are correct)

Do i need to put it on my script? Or do i need to do it on the promt

in the terminal prompt please (the command will list your sh files and their permissions)
(sorry there was a typo and I just fixed it, ls -la *.sh)

Thanks for your information. The command gives me the results on the promt. But my checklist about this problem is not green.

It return me this message: SUBTASKS 1.1 :8 Your “insert_data.sh” and “queries.sh” files should have executable permissions

If you can post the result of the ls command pls? I was interested to see what your .sh files were set to.

codeally@e1b019b37697:~/project$ ls -la *.sh
-rw-r–r-- 1 codeally strove 286 Sep 18 19:30 insert_data.sh
-rw-r–r-- 1 codeally strove 1123 Sep 18 19:30 queries.sh

Okay do you see the first column there? It shows that your scripts are for read and write permission but do not have execute permission.

So run this to fix it.

chmod +x *.sh
1 Like

thanks a lot problem is fixed!

Now it gives me.
-rwxr-xr-x 1 codeally strove 286 Sep 18 19:49 insert_data.sh
-rwxr-xr-x 1 codeally strove 1123 Sep 18 19:49 queries.sh