25 + 5 Clock test fail : 8. Timer has not reached 00:00

Link to the code and test
I hope to get some help on this project. The current score is 20/29.
It is weird that the test failed.

Failure List :

    1. I can see an element with corresponding id=“time-left”. NOTE: Paused or running, the value in this field should always be displayed in mm:ss format (i.e. 25:00).

→ I have checked the code and the example, the format is the same. I wonder why it failed

    1. When a session countdown reaches zero (NOTE: timer MUST reach 00:00), and a new countdown begins, the element with the id of “timer-label” should display a string indicating a break has begun.

->The error said :

Timer has not reached 00:00.

But actually, it reaches 00:00 I see it carefully, I try some solution in other thread in the forum, but it does not solve the issue
And many other issues have the same error:

Timer has not reached 00:00

Any help is appreciated!
Thank you!

Hi,
I had a look at your clock. It looks good! I’m still not sure what may cause the tests to fail. Your clock seems to display the times correctly. However I’ve noticed something that doesn’t follow the requirements. Your reset button resets the clock as expected, fine, but if you click multiple times on reset, it starts the timer and stops it. Reset button should just put the clock to it’s original state, nothing more. Evene if you click multiple times! It’s the start/reset button that should run stop the clock. I think that what make the clock fail the test or at least definitely reset button should have the required behaviour.