A quick update on freeCodeCamp's servers

Hey everyone, thanks for your patience with our servers.

Here’s what happened, what we’ve learned from the experience: https://www.freecodecamp.org/news/freecodecamp-servers-update-october-2019/

You can use /learn without signing in. If you insist on signing in anyway so that you can save your progress, try this method.

We did a database backup before we started maintenance on Tuesday, so your data should be fine.

This forum, news, and our YouTube still work fine.



La fin de la mise à jour est prévue pour quelle date?
Merci pour le travail que vous faites, sans freecodecamp je ne pourrais pas me former !

Bonjour, vous êtes sur un forum international.

Il serait préférable que vous posiez vos questions en anglais si vous souhaitez obtenir une réponse plus rapidement.

Pour répondre à votre question la fin de la “mise à jour” n’est pas daté.

Etant donné que le site rencontre des problèmes de maintenance dû à l’API d’authentification.

Cordialement Stéphane

Hello, you are on an international forum.

It’s better if you ask your question in english. Since most of the people here speak this language to communicate information. You will get an answer faster.

To answer your question we don’t know when the maintenance will ends.There is issues with the Authentication API.

Best regards,

We have just resolved the issues with our backend servers and the API. Let us know if you face issues.

1 Like

When trying to sign in with Github, Google, and email I get this message:

Oops! Something went wrong. Please try again in a moment.

This is the same message I was getting throughout the day. I tried clearing website data and still get the message.

1 Like

Please email our support: team@freecodecamp.org or DM me with your username and registered email. I will look into it.

I am so contributing to freecodecamp when I get that first paying developer project!
Love the indomitable spirit!
Keep strong.

I hope I’m in the right discussion.

I have another issue:
I wanted to post my solutions for
Information Security and Quality Assurance Projects - Personal Library

I went here:

I filled in the fields:

After clicking “I’ve completed this challenge”
I get a lightbox: “Submit and go to next challenge”
and then I’m redirected to: Anonymous Message Board-challange

On the next page there is a message “We cannot reach the server…”
at top of the page
but it is faded out very quickly so it’s difficult to read.

and the solution is not listed in my portfolio


All that login stuff works fine now

Thanks for reporting, yes this seems to be a bug. We are looking at it.


1 Like