Advanced Bash - Kitty Ipsum Translator - stuck on step

Hi All,

I’m getting stuck on the desktop version of the Learn Advance Bash Kitty Ipsum Translator course. The below basic step just doesn’t want to pass.

I have tried resetting the terminal, the course, rebuilding the container, restarting the whole course and nothing has worked so far. Any suggestions for next steps? Would it be something at the course end?

Many thanks for your help!



have you tried this:

(but with the modification of running the command you need instead of sh)

Thanks for the resonse hbar1st! Yeap tried that a bunch of times - i’ve done all the resets I can think of.

Including exiting the terminal and opening a new one after resetting @higjo860? If not, I would make sure to give that a try. Well, restarting the course should have fixed it if that was the problem. So that probably won’t work.

We have been optimizing these courses for the web based version - there’s a chance a change we made broke something for running them locally. I will open the local version when I get a chance and see if I can reproduce the problem and dig into it. Until then, if it truly is a bug that is impossible to get around - you could try one of the other courses, or the web based version (where you can earn your certificate).

I will get back to you if I come up with anything.

Thanks heaps moT01 - yeap I tried exiting the terminal and opening a new one. I have tried using the web based version but couldn’t get past the “Starting virtual Server” step. However I’ve tried again today and seems to be working! Will let you know if I’m still getting stuck. These courses are awesome btw

1 Like

Yuss! Success in the web version!

What is “the web-based version”? Is that the one you see normally when you do the core via freecodecamp?

You can either do the course in your browser (web-based version) or through VS code on your desktop via Docker. See Link

1 Like

stuck on some other challenge,tried closing and reopening the terminal but nothing happens.

Hi, I am also getting stuck in the Kitty Ipsum Translator, I enter the suggested command, code works fine, but it is still not accepted. Already in the web version.

Same here mate. did you get past this?? if yes, how??

Have you tried a soft reset?

Local version seems to be still broken.

have you tried to close the terminal and open a new one?

I’ve tried all proposed fixes in this thread, as well as restarting the container and the tutorial. It doesn’t work locally, it does work in the web-based app though.

perhaps you should open a new topic for this as it is a local install.

I can only suggest for you to read the thread carefully. This issue has been initially brought up by higjo860, who ran into the same issue, while going through the course locally. This is the correct topic.