An issue with "Starting virtual server" on Relational database course

Tell us what’s happening:
Describe your issue in detail here.
I’ve got a problem with “starting virtual server” while making through the Celestial Bodies Database. Tried everything - no luck. Tried reloading the page, the coockies are enabled, no blocking extensions installed, tried using different browsers, deleted project from the dashboard on CodeAlly. No ideas left - same outcome.

I’ve got the same situation with all lessons of the course.
What else to try? Thanks alot.

Your code so far

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/101.0.4951.67 Safari/537.36

Challenge: Build a Celestial Bodies Database

Link to the challenge:

Are you still seeing this issue @mactevl?

Unfortunately, yes. I’ve been trying to nail it like several days. Regarding web browsers - firefox and chrome show the same thing and there is no difference if it is Windows or Android . Also, starting a completely new project directly from CodeAlly ends up with the same issue. So, I think the root of it is at CodeAlly, but I couldn’t find any contact for support.

I don’t know @mactevl. Seems like you tried everything I would have suggested. You could check your console and share any errors or anything in there and I could maybe help figure it out from there.

So, I’ve started with the console and ended up with creating new accounts for freecodecamp and github/codeally. Much to my surprise, I was able to start a project. So, as appeared, the problem was that my main github account became private at sudden, and as result I couldn’t start virtual server on CodeAlly, although it wasn’t complaining during my subsequent visits. moT01, thanks alot.

1 Like

So, I’ve got the same problem again. I’ve just finished the World Cup Database but didn’t have time to back up with GitHub-the virtual machine had been shut down sooner than usual. And now, I can’t start a virtual server on any project, neither through FreeCodeCamp nor directly from Codeally.
All that happened while I was using my second (reserve) Github account, through which I had been able to overcome the issue and continue the course on databases. So, I have ended up with the second GitHub account, which encountered the same problem. I don’t want to go to the new cycle from here. Any ideas are appreciated.

I’m having this issue today as well with the World Cup project.
It was working a few hours ago and then just randomly stopped.
I tried running it directly from and it just spins on the virtual server step as well.

Also having the same issue

It seems to be an issue with all projects for me.

Well, as I can see, something went wrong on CodeAlly’s side …

Any update on this? As i am still unable to get through :X

I’ve had this issue all day today as well. CodeAlly is stuck at “Starting Virtual Server” on freecodecamp and on the CodeAlly website, for all projects. I’ve tried refreshing, switching browsers, and restarting the computer. It still isn’t working… Any fixes?

Hi @moT01! I am facing the same issue and am not able to cut through this :((. Is it a problem on the’s side?

Hey @moT01! I have read that there is a downloaded version of the relational database course offered by freeCodeCamp which runs using Docker and VSCode. Can I complete the lessons on the downloaded version and upload the main projects on freeCodeCamp website to earn the certification?

For the time being, you would have to re-complete the projects using the web version @thegreatsquark20. You can finish them with that downloaded version - but it won’t count on your freeCodeCamp profile. So you would have to save all the code you created locally, open up the web version, and put the code in there to finish the project again.

@moT01 Thank you so much for your time and help!

Ok. Today I’ve been able to log into my World Cup project without any data loss and with the same account. All day the day before CodeAlly had been loading the project without any Development Environment or the Code road. So don’t hurry to delete your projects from CodeAlly and start over.

1 Like

Hi everyone,
I have the same problem right know. During coding virtual machine suddenly closed and now it is not opening. Someone have the same issue?

Same here, left the virtual machine about an hour ago, came back and i cant enter anymore, guess we will have to wait it out

Already working on my side. :slight_smile: