Certificate Expiry Issue in 'Learn Bash and SQL by Building a Bike Rental Shop - Build a Bike Rental Shop' Course

Tell us what’s happening:

I completed the course Learn Bash and SQL by Building a Bike Rental Shop - Build a Bike Rental Shop. However, when I returned to the course and clicked on “Start the course”, I encountered an error. I also tried clearing the cookies but the issue persisted.

The error message I received in Firefox is: Did Not Connect: Potential Security Issue

Firefox detected an issue and did not continue to app.codeally.io. The website is either misconfigured or your computer clock is set to the wrong time.

It’s likely the website’s certificate is expired, which prevents Firefox from connecting securely.

The issue is most likely with the website, and there is nothing you can do to resolve it. You can notify the website’s administrator about the problem.

The certificate for codeally expired on 10/22/2023.


I am unsure about how to update my course progress due to this issue. I would appreciate any assistance or guidance on how to resolve this.

Your code so far
[Not Applicable for this issue]

Your browser information:
User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:109.0) Gecko/20100101 Firefox/118.0

Challenge: Learn Bash and SQL by Building a Bike Rental Shop - Build a Bike Rental Shop

Link to the challenge:

I’d like to add that I’ve tried accessing both new and old courses, and the issue isn’t limited to just one browser. I’ve tested this on both Firefox and Edge, and every attempt leads to the same error message:

This Deployment has been disabled.

Your connection is working correctly.

Vercel is working correctly.

ID: arn1::g6p7q-1698203072292-ca0faa589000

Platform Error Codes | Vercel Docs

I’m really eager to add solution links to the course in freeCodeCamp and reflect my local progress.

  1. Is there an estimated time for when this will be resolved?
  2. Or perhaps there’s a workaround to add the solution links without having to run Code Ally?

Any help would be greatly appreciated.

Update: The issue resolved itself.